zeovit.com EcoTech Marine LLC  

Go Back   zeovit.com > General Discussion Forums - International > General Discussion - English

General Discussion - English General Marine Aquaria Discussion with and without ZEOVit.

Active Threads
0 lost post
Last Post: G.Alexander
Posted On: Today
Replies: 3
Views: 67
0 Wechsel auf Zeovit - Werte zu hoch
Last Post: G.Alexander
Posted On: Today
Replies: 5
Views: 146
0 switching to zeo system possibly
Last Post: G.Alexander
Posted On: Today
Replies: 25
Views: 177
0 new to zeovit
Last Post: G.Alexander
Posted On: Today
Replies: 23
Views: 917
1 New to zeovit - Brazil
Last Post: G.Alexander
Posted On: Today
Replies: 1
Views: 19
0 Increase in PO4 and Nitrates
Last Post: G.Alexander
Posted On: Today
Replies: 9
Views: 238
0 Phosphate in Zeo Life
Last Post: Meir
Posted On: Yesterday
Replies: 6
Views: 195
0 Growth
Last Post: Dzeo
Posted On: Yesterday
Replies: 15
Views: 374
0 New to Zeovit
Last Post: Bugger
Posted On: Yesterday
Replies: 10
Views: 479
0 Zeovit - brown bottom
Last Post: ohashimz
Posted On: Yesterday
Replies: 11
Views: 163
More...
  #91  
Old 04-23-2018, 10:30 PM
johntekin's Avatar
johntekin johntekin 目前線上
ZEOhead
 
Join Date: Nov 2010
Location: Dallas, TX
Posts: 358
Default

That's a very fair point. I appreciate the feedback and will change them out tomorrow
Reply With Quote
  #92  
Old Yesterday, 07:20 AM
ohashimz ohashimz 目前線上
ZEOhead
 
Join Date: Sep 2016
Location: USA
Posts: 364
Default

4 months old rodi should be ok honestly. Not sure how much did you use over only 4 months.
If you reading zero TDs and your rodi is good against chlorine and chloramine you should be good.
I use brs 6 stages chloramine system.
Recently modified it to 8 stages for extra di stages but thays an overkill for sure lol
Reply With Quote
  #93  
Old Yesterday, 08:13 AM
johntekin's Avatar
johntekin johntekin 目前線上
ZEOhead
 
Join Date: Nov 2010
Location: Dallas, TX
Posts: 358
Default

Thanks for the response.

oO you all think it is possible that low iodine level could cause the issue? I just got my results back from the titration lab, and it said that iodine was very low...?

What product do I use to raise and how much?
Reply With Quote
  #94  
Old Yesterday, 12:29 PM
ohashimz ohashimz 目前線上
ZEOhead
 
Join Date: Sep 2016
Location: USA
Posts: 364
Default

Quote:
Originally Posted by johntekin View Post
Thanks for the response.

oO you all think it is possible that low iodine level could cause the issue? I just got my results back from the titration lab, and it said that iodine was very low...?

What product do I use to raise and how much?
highly unlikely its the iodine. I do Triton ICP monthly and rarely have got above zero my growth is not bad at all.
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 7 (0 members and 7 guests)
 
Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT -5. The time now is 04:21 AM.


Powered by: vBulletin Version 3.8.7, Copyright ©2000 - 2009, Jelsoft Enterprises Ltd.
Copyright by ZeoVit.com